Cloudflare Network and Resolver Issues (DNS)
Incident Report for Servebolt
Postmortem

*Post Mortem from Cloudflare
*
Today, from approximately 21:12 to 21:39 UTC, a configuration error in our backbone network caused an outage for Internet properties that use Cloudflare. During this period we saw traffic drop by about 50% across our network. Because of the architecture of our backbone this outage didn’t affect the entire Cloudflare network and was localized only to certain geographies.

This service disruption was not the result of an attack. It was caused by a network configuration error which caused traffic across our backbone to be sent to a single router on our global network. This quickly overwhelmed that router and caused Cloudflare network locations connected to the backbone to fail. Other locations not connected to the backbone continued to operate normally.

We have posted an initial summary of this incident on the Cloudflare blog. We’ve already made a change to the backbone configuration to make sure that this cannot happen again.

We’re deeply sorry about how this disruption may have impacted your services. Our business is based on trust and transparency and we are committed to your success.

~The Cloudflare Team

Posted Jul 18, 2020 - 10:18 CEST

Resolved
Cloudflare had a service disruption affecting our customers that use Cloudflare DNS, and large parts of the internet in general. The event lasted for 30-40 minutes before services became available.

Cloudflare writes: "This afternoon we saw an outage across some parts of our network. It was not as a result of an attack. It appears a router on our global backbone announced bad routes and caused some portions of the network to not be available. We believe we have addressed the root cause and are monitoring systems for stability now."

More information is available on https://www.cloudflarestatus.com/
Posted Jul 17, 2020 - 23:00 CEST