Routing issues via Cloudflare

Incident Report for Servebolt

Postmortem

On March 25th, 2025, Servebolt experienced a network routing issue that resulted in degraded performance and, for some users, temporary unavailability. The issue primarily affected traffic routed through Cloudflare in Amsterdam and was due to routing irregularities between Cloudflare and ERA-IX (Eranium Internet Exchange), which lies outside Servebolt’s infrastructure.

While the root of the problem was external, we treat any service disruption with the utmost seriousness. Our team responded quickly and worked actively with our upstream partners to identify and resolve the issue.

Impact

  • Who was affected: Clients with traffic routed through Cloudflare’s node in Amsterdam, primarily clients in the Netherlands and nearby regions. This includes traffic to website running Accelerated Domains and Servebolt CDN.

  • What happened: Intermittent or complete unavailability of services.

  • Who was not affected: Clients served via other regions of the Cloudflare network, or clients not using Cloudflare, Accelerated Domains or Servebolt CDN

Preliminary Root Cause

Current information indicates that the operator of ERA-IX, a major internet exchange in Amsterdam, identified a routing issue between their systems and Cloudflare at 10:46 CET. To mitigate the issue, they temporarily disabled their connection to Cloudflare at 11:16 CET.

However, the change did not fully take effect across all upstream networks. This caused inconsistencies in how traffic was routed, which continued to disrupt connectivity for some users.

Although our upstream provider was not the source of the issue, a manual refresh of their network configuration at 15:30 CET successfully restored normal traffic flow between Cloudflare, ERA-IX, and affected networks.

This incident occurred within one of the foundational layers of the internet — completely outside of Servebolt’s infrastructure — but it still impacted how some users were able to reach our platform, primarily in and around the Netherlands.

Identifying the root cause of incidents at this level of the internet is often time-consuming. The infrastructure involved spans multiple independent networks, each with limited visibility into the others. This is why resolution and confirmation took several hours, despite active collaboration between the involved parties.

Next Steps

We are currently awaiting further clarification from Cloudflare, Blix, and Eranium. A full and final report will be published once this information is available — expected this week.

Posted Mar 25, 2025 - 19:37 CET

Resolved

This incident has now been resolved. We will continue to monitor the impacted network, and work with our partners to fully understand the root cause.
Posted Mar 25, 2025 - 16:28 CET

Monitoring

We believe the issue has been found, and are currently monitoring the network.
Posted Mar 25, 2025 - 16:19 CET

Update

Working with our ISP and Cloudflare, we believe we are close to a solution for the issue. We will give more updates as we move forward.
Posted Mar 25, 2025 - 16:12 CET

Update

We are noticing other platforms with the same issues as us.
We are currently trying to manually re-route all network traffic outside of the affected area.
Posted Mar 25, 2025 - 14:56 CET

Update

We are continuing to investigate this issue.
Posted Mar 25, 2025 - 14:32 CET

Update

We are continuing to investigate this issue.
Posted Mar 25, 2025 - 14:04 CET

Update

Ongoing investigations indicate that the issue is likely within the Cloudflare network. We are actively collaborating with Cloudflare to resolve the matter.
Posted Mar 25, 2025 - 14:02 CET

Update

As we are continuing to investigate the issue, we have identified that our clients are still receiving traffic to their sites, although not at the same routes and volume as expected. We will continue to investigate the root cause.
Posted Mar 25, 2025 - 12:43 CET

Update

We are continuing to investigate this issue along side our ISP.
Posted Mar 25, 2025 - 11:44 CET

Investigating

We are currently investigating a routing issue in Amsterdam. More information will be shared when it becomes available.
Posted Mar 25, 2025 - 11:21 CET
This incident affected: admin.servebolt.com, Cloudflare Infrastructure, Cloudflare Network, Accelerated Domains CDN/Cache, Accelerated Domains CDN Cache Purge, Accelerated Domains Provisioning, Accelerated Domains Image Resizing, and Accelerated Domains Firewall.