Control panel version 27.17
Incident Report for Servebolt
Resolved
This incident has been resolved.
Posted Feb 10, 2020 - 10:58 CET
Investigating
We are rolling out a new version of the admin panel.
Posted Feb 10, 2020 - 10:28 CET
This incident affected: admin.servebolt.com.