New Let's Encrypt SSL ordering failures

Incident Report for Servebolt

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 18:07 CET

Investigating

We are currently experiencing issues with ordering new Let's Encrypt SSL certificates. Existing certificates and sites remain unaffected. Our team is investigating the cause and working to restore normal certificate issuance as soon as possible.
Posted Oct 28, 2025 - 18:05 CET
This incident affected: admin.servebolt.com and Servebolt API.