Support chat and billing service provider currently experiencing issues. We will update as more information comes in.

Incident Report for Servebolt

Resolved

Services now appear stable.
Posted Dec 22, 2021 - 16:38 CET

Investigating

We are currently investigating this issue.
Posted Dec 22, 2021 - 14:29 CET